Help:Reporting bugs

From RSNAV
Jump to: navigation, search

Post any bugs you've found, or fixes you have. Please provide MMI version, RSNav product number, and vehicle year and model.



High Priority[edit]

OEM Backup Camera functionality[edit]

  • When you put vehicle in reverse while Android screen, the parking camera appears. When put in drive, the rear screen disappears. It should remain viewing. OEM function is to display until > 8 mph speed which happens in Audi MMI mode. This permits driver to correct a parallel parking distance forward and back motions until completed. Android screen should stay on backup camera mode similarly.
  • For the Manual Transmission model, when you put the vehicle in reverse while in the Android screen, the parking camera screen does not appear. You need to press one of the MMI buttons manually for the rear-view display to display.

Normal Priority[edit]

[2019-05-19] music playback track position not remembered when playing files from USB Google Play Music, Poweramp and various other music players are not able to remember (or recall?) the last track position when playing files directly from an attached mass storage device. However, when copying the files to the devices internal storage all apps _can_ remember the position. Ideally one should not be forced to copy contents to internal storage as USB storage can easily exceed internal available memory.

- System: M8.q5.2.0.1.0412206 - MCU: 7.6.1212 - Can: Q5.v2.0.2.181226 - 10.25" HW3.0, (original 3G MMI Basic), 2012 Audi A5 quattro facelift (EU).


[2019-05-19] music track control non-functional with the latest update. Track control only works while in the native bluetooth app compared to before when it was available on any screen/while using any other app.

- 10.25 HW1.0 -MMI 3g+

Fixed[edit]

Brightness Reversed[edit]

  • Android brightness setting is reversed.
Daniel's Comment: This cannot be fixed as it is a hardware design issue. For Automotive display, the brightness must start from 100%, so for that reason, we need to connect the brightness control in reverse, unlike conventional Android device. 

Low Quality Google Voice[edit]

  • My Google voice for Maps and Now cracks and pops, like high treble, low quality audio. It is using the higher quality data voice, and not TTS voice, but it doesn't sound as good as music played through the RSNAV.
Daniel's Comment: we have adjusted volumes from 2019-April update. 

Data Connection not working[edit]

  • I've recently started having the problem where the mobile data connection stops working, despite Android showing it has a signal (4g or 3g). Daniel is currently troubleshooting the problem with me.
 There have been few cases that ambient temperature is affecting cellular data capability. We notified the modem supplier.
 Daniel's Comment: As of 2019, Data connection is mostly good, but some network service provider is blocking unregistered IMEI. You must call your network service to provide and let them know the IMEI of the device and ask permission to register their networks.

Multitronc in manual mode 8 gears the 2nd gear activates rear camera[edit]

  • AUDI A5 2.7TDI MULTITRONIC 2008 RADIO SYMPHONY - RSNAV (RSA70201)
 1-With the change of MULTITRONIC 8V gears in manual mode the rear camera application is activated each time you select the 2 gear. (Is very annoying)
 
 <POSITION GEARS>
 P-No Active
 R-(Active Camera)
 N-No Active
 L-No Active
 S-No Active
 1-No Active
 2-(Active Camera)
 3-No Active
 4-No Active
 5-No Active
 6-No Active
 7-No Active
 8-No Active
 
 2-The reverse gear application hangs up and does not show the directional lines.
 It works sometimes and sometimes it does not.
Daniel's Comment: As of 2019, you must specify if you have manual transmission before you place an order. This only can be prevented by minor hardware modification only for manual cars. 

Parking Brake Malfunction and TPMS malfunction[edit]

  • Audi S5 4.2 Manual 2008 Radio Radio Symphony
  • Audi A5 2.7 TDI MULTITRONIC 2008 Radio Symphony - RSA 70201 (same problem)
 Every time you start the car the Parking brake Malfunction error comes up and after 15min of driving the TPMS malfunction error comes up. The parking brake still functions but the errors are constant.
 Also, have a problem with the reverse camera guidelines and PDC radar not functioning after a few days.
 Possible Solution: Using Ross-Tech VCDS, clear the airbag fault code first, and then clear the parking break code. Do it manually on each control unit, not clearing DTC option in Automatic Scan menu. This was caused by turn the system on while the hazard flasher was detached during installation. Also, Disable Park Radar Key in Realsun Setting, if you don't have OEM PDC. If you have OEM backup camera and OEM PDC, Enable Park Radar Key, and choose rear camera type as Original in Realsun Setting.

This does not solve the problem, steps followed as per "possible solution", parking brake malfunction comes back as soon as the error is cleared when manually going into the control module

VCDS Error report Address 53: Parking Brake Labels: 8K0-907-801-V1.clb Control Module Part Number: 8K0 907 801 E HW: 8K0 907 801 E

 Component and/or Version: EPB Audi B8   H05 0060
          Software Coding: 
           Work Shop Code: WSC 00000 000 00000
                     VCID: 316973F2686B68CE2E-8064

1 Fault Found: 00381 - Databus Instrument Cluster

           004 - No Signal/Communication - MIL ON
            Freeze Frame:
                   Fault Status: 11100100
                   Fault Priority: 3
                   Fault Frequency: 1
                   Reset counter: 243
                   Mileage: 104904 km
                   Time Indication: 0
                   Date: 2018.04.05
                   Time: 16:24:03

Freeze Frame:

                   Voltage: 12.50 V
                   Count: 81
                   Speed: 0.0 km/h
                   Hex Value: 0x0263
                   Hex Value: 0x0001
                   Hex Value: 0x1010
 Suggestion: 00381 Fault is known to be related to unstable battery power. It may be due to intermittent electric power shortage of the vehicle. Check if there is an accessory that consumes too much electric power beside our device. Our devices draw typically 400mA and 900mA at peak. Also, above logged vehicle's battery seems to low if its motor was running.

Battery has been replaced and the problem still persist.

VAGCOM scan with the new battery

Parking Brake Module Monday,28,May,2018,16:10:55:16946

               Address 53: Parking Brake       Labels: 8K0-907-801-V1.clb

Control Module Part Number: 8K0 907 801 E HW: 8K0 907 801 E

 Component and/or Version: EPB Audi B8   H05 0060
          Software Coding: 
           Work Shop Code: WSC 00000 000 00000
                     VCID: 316973F2686B68CE2E-8064

1 Fault Found:

00381 - Databus Instrument Cluster

           004 - No Signal/Communication - MIL ON
            Freeze Frame:
                   Fault Status: 11100100
                   Fault Priority: 3
                   Fault Frequency: 1
                   Reset counter: 90
                   Mileage: 106958 km
                   Time Indication: 0
                   Date: 2008.05.27
                   Time: 00:18:54
            Freeze Frame:
                   Voltage: 14.00 V
                   Count: 81
                   Speed: 0.0 km/h
                   Hex Value: 0x0263
                   Hex Value: 0x0001
                   Hex Value: 0x1010

ABS Brakes Module Monday,28,May,2018,16:10:55:16946

               Address 03: ABS Brakes       Labels: 8K0-907-379-V1.clb

Control Module Part Number: 8K0 907 379 AD HW: 8K0 907 379 AD

 Component and/or Version: ESP8 quattro  H04 0060
          Software Coding: 114D00
           Work Shop Code: WSC 06325 123 12345
                     VCID: 7BF591DAFAA7529EC4-802E

1 Fault Found:

00473 - Control Module for Elect. Park/Hand Brake (J540)

           013 - Check DTC Memory
            Freeze Frame:
                   Fault Status: 01101101
                   Fault Priority: 6
                   Fault Frequency: 1
                   Reset counter: 90
                   Mileage: 106958 km
                   Time Indication: 0
                   Date: 2008.05.27
                   Time: 00:20:36
            Freeze Frame:
                   Hex Value: 0x0000
                   Hex Value: 0x4782
                   Hex Value: 0x0016
                   Hex Value: 0x02B2
                   Hex Value: 0x00FF
Daniel's Comment: This was an issue with CANBUS gateway bypass pin check and CANBUS software. As of 2019, it has been eliminated. 

Volume Adjust App misbehaving on Bluetooth call[edit]

  • Every time you go into the Bluetooth app to make a phone call the main volume drops down to 0% in order for the music to be silent in the background and the voice call volume also drops to about 60% (even if it was set to a 100%). During the call you need to get out of the bluetooth app go to the volume app increase the volume so that you can actually hear the other person correctly. Also when finishing the call the music will be silent and you need to increase the volume in the volume app higher in order to hear music again.
 This is not a Bluetooth problem, but it's Volumeadjust.apk's bug, which is designed to mute any background sound for the BT voice call, but it seems the app is not sensing BT call termination properly. This will be fixed sooner or later.
Daniel's Comment: This has been fixed as of April 2019

OEM MMI controls Unresponsive[edit]

  • When OEM MMI option is checked off to display before the RSNAV Unit, The MMI system is unresponsive to control panel commands until the display is first switched over the the RSNAV android interface (Device : 10.25) Android S5 MMI HN+
Daniel's Comment: This has been fixed as of April, 2019. It was a CANBUS firmware error. 

OEM Display disconnects[edit]

  • When in the OEM Audi interface, the screen continually disappears and goes black for 5-10 seconds at a time. This experience of the screen going dark, is only when in the Audi OEM interface app within RSNAV. In any other app, this does not happen. This issue has only started since flashing to latest May 2018 firmware update. 2010 A4 with 10.25" 12205 Unit / Concert HU

System:M8.q5.1.0.1.05311646 Mcu:5.2.0205 Can:Q5.V1.1.9.180423 SN:rs0108170700289 TW's Video of bug occurring

Daniel's Comment: This is caused by outdated 'Autoplay App'. YOU MUST UPDATE THE APP. See software update section of this wiki. 

Climate Control Overlay[edit]

  • The climate control overlay is in Celsius only and cannot be changed
  • The overlay cancels anything that is split screened.
  • on 10.25 in version, the right climate control overlay shows up outside of it's box
  • on 10.25 in version, after changing the fan speed, the overlays continue to randomly pop up every minute or two, until the device is rebooted. After reboot, and no adjustments to the fan speed, the audi-wind application no longer pops up uncontrollably. closing the Audi-wind app without rebooting the RSNAV does not fix problem. This is on May 2018 SW version.
  • on 7" occasionally there´s a lag when showing the overlay. Besides, some characters appear in Chinesse, though the temp is absolutely readable.

Proposed fix: allow the AudiWind service to be disabled and allow configuration of the application.

Daniel's Comment: Display Chinese, reporting wrong value has been fixed as in April 2019.  

Bluetooth Functionality[edit]

  • Bluetooth serial communication(e.g. Bluetooth Mouse, keyboard, and OBD II adapter) is disabled on all model for now because a handling protocole is not yet ready.
 DO NOT POST A PROBLEM IN VAGUE TERMS. PREVIOUSLY, THE SECTION STATES 'BLUETOOTH IS DISABLED FOR 10.25"'. THIS IS HEAVILY MISLEADING STATEMENT. THIS IS NOT YOUR REGULAR ANDROID TABLET, THE DEVICE IS MOSTLY ACTS AS RECEIVER, NOT TRANSMITTER, THAT'S WHY YOU CAN'T ACCESS BLUETOOTH SETTINGS IN THE ANDROID SETTINGS. PRECISELY, BLUETOOTH HANDS-FREE(HFP), MUSIC STREAMING(A2DP, AVCTP) WORKS FLAWLESSLY.

Still having a problem after the June 2018 updated (enabling serial bluetooth) media remotes do not connect, only OBD II

Even if the bluetooth device has no pin to pair

Daniel's Comment: This has been fixed as in late 2018. A video instruction of how to is in Youtube. 

Default nav app[edit]

  • In "Realsun settings-navi app choice" no new navs installed are available. This selection allows wheel button hot start for the nav selected in Realsun.

User feedback: I found then when changing the Navi app in the launcher by long-pressing the icon, this will also re-assign the buttons on the steering wheel and MMI.

 Daniel's Comment: This has been fixed as of 2018. 

Startup Brightness[edit]

  • Upon startup, the unit does not check what the status of the headlights is. Example:if it's dark out and I start my car, when Android finally comes up the brightness is very high. However if I toggle the headlights OFF then back ON, Android brightness dims to where it should be. There should be a check when Android boots to check headlight status and adjust accordingly.
 Daniel's Comment: This has been fixed as of April, 2019

Brightness on Startup[edit]

  • Ajusted: Unit needs to start up at 0% brightness, as Audi animation can be blinding at night. I currently wait till the Audi logo comes up to begin driving.

OEM Reverse Camera Not showing[edit]

  • Fixed: Change setting to original in Realsun Setting under Camera selection option.

Airbag light is on[edit]

  • Fixed: Clear the error using VCDS or Carista. If the error comes back, you may need to contact RSNAV for a new flasher board.

Language Translations to English[edit]

 Fixed as suggested
  • Boot screen currently says "using navigation may not divert your attention from the road and traffic" It should say something like "Distracted Driving Kills. Pay Attention to the Road. Use the System only when Safe." or "Using Navigation Diverts Your Attention from the Road. Use only when Safe to do so."
  • "Realsun Setting" should read "Realsun Settings"
  • "System volume" should read "System Volume" This keeps with the same punctuation throughout the settings menu
  • In "System volume" suggest "volume value" change to "System Volume" or "Master Volume" - I am assuming this is the master volume control just like the volume control on the radio or steering wheel
  • In "System volume" there appears to be a check box to reset to default volume. This should read "Reset to System Default Value"
  • Bluetooth Settings- "Reset the bluetooth" should be changed to "Reset Bluetooth". "In the search" should be changed to "Search for Available Bluetooth Devices"
  • Bluetooth Settings - when a device is connected and shows up, it should read "Connected Bluetooth Devices"
  • "Network Settings" should read "Cellular Network Settings" This takes you to the android settings menu to configure a SIM card.
  • "Video In-Motion Lock" could be changed to "Video in Motion Settings". I am not sure what "safe lifting" refers to, but i think it is safe operation? if so, this should say "Video in Motion" with the check box saying "Enable Video in Motion" I am not sure I fully understand what this setting is telling me it can and cannot do. May need more info to clarify and get a better translation.
  • "Reverse trajectory" should read "Rear Camera Parking Lines" Within that setting "Hidden" should say "Show Rear Camera Parking Lines" and "Hide Rear Camera Parking Lines"
  • Turn Off Display opens a menu which doesn't really refer to the first option (turn off display). This should say "Turn off Display" and then in the next screen "Close Display" with Yes or No. The yes and no do not follow previous menus with a radio icon. Need to add icon to keep everything the same.
  • "System upgrade" is misleading. You don't upgrade in this menu. This should read "System Version Information"
  • "Restart the system" should read "System Reboot" Radio keys are missing in the next menu.
  • "Restore" should read "Factory Data Reset"
  • "Navigation App Choice" should change to "iNav Button Quick Launch"
  • "Reverse View Setting" should change to "Rear Camera Settings" "Original car camera" should change to "OEM Rear Camera Installed". "Equipped with a camera" should change to "Aftermarket Rear Camera Installed"
  • "Parking Radar Setting" should change to "Parking Radar Settings". "Reversing radar" should change to "Rear Camera Radar" "Display" could be changed to "Show Radar" "Hidden" could be changed to "Hide Radar"
  • "Startup Interface Setting" could be changed to "Startup System Options". "Original car interface" should be changed to "OEM Audi Interface" "Main interface" should change to "RS Nav System"
  • "Music on Background" is a little confusing. i understand its muting whatever music is playing when navigation needs to say something. Should be "Music Pause for Navigation". Within that setting, it should say "Pause Media when Navigation is Active"
  • "Navi Button Setting" should read "iNav Button Settings" Map doesnt really tell you what its opening. This should read google maps, or waze, etc. "Browser" should read "Internet Browser". "Navi Key" should read "iNav Button".
  • "Overlay Display Time" - i dont really know what this is referring to. need more information. Within this menu, "Not show" should read "Do Not Show".
  • "Wheel Key" should read "Steering Wheel Button Settings"
  • Car style menu - "Car Style Choose" should read "Car Style Icon"

I see in the realsun settings menu the circle has two 90* lines above it. Looks like a bounding layout that shouldnt be showing up? If and when these changes are made, pay attention to punctuation and capitalization.